Booster Pump failure

Support forum for troubleshooting well pumps, water pumps and their applications.

Booster Pump failure

Postby JimRea » Mon Feb 24, 2014 2:50 pm

I have several Gould 2AB22HM1F2E0 pumping systems scattered around my ranch. All have given excelllent service over many years. Recently, one pump could not be restarted after having the power removed from it for a short time (circuit breaker tripped for other work on the break panel). After trying various troubleshooting ideas throughout the day (such as verifying good connections, tapping on this and that, etc), it started just as it always does when the breaker was engaged a last time. The pump has continued working flawlessly for the past month or more since this earlier event. A few days ago, the pump was again turned off at the circuit breaker for other work, and again failed to restart when its circuit breaker was re-engaged. Trying everything I knew failed to result in a restart.

No lights whatsoever come on when the restart is attempted. Voltage at the controller is perfect, and all switches are properly set, just as they have been for years. Removal of connection to pressure transducer and reconnect makes no difference.

I've given up, so can you help?
JimRea
Member
 
Posts: 1
Joined: Mon Feb 24, 2014 2:40 pm

Re: Booster Pump failure

Postby dlamp67 » Mon Feb 24, 2014 3:22 pm

It sounds like you may have had an intermittent issue with the controller. Unfortunately, there is not much you can do with the controller, as far as repairs are concerned. If there is no light coming on, then, either the controller is bad or you have no or very low voltage at the controller. I would verify that you have 230 volts at the controller. Also, check line voltage to ground. It may be possible you have dropped a leg and the controller is only seeing 115 volt.
dlamp67
Professional
 
Posts: 275
Joined: Mon Jul 30, 2012 1:46 pm


Return to Well & Water Pump Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest